 
Написать программы,выполняющие данные задачи. Для всех числовых типов данных использовать
целочисленный тип. 1.Написать программу, которая считает количество секунд в часе.Пользователь вводит количество часов, а программа в ответ выводит сколько это секунд. 2.Написать программу, которая считает угловой коэффициент прямой, проходящей через точки А и В. Пользователь вводит последовательно координаты точек, а программа выводит угловой коэффициент по формуле k=Ув-Уа/Хв-Ха. 3.Написать программу, которая генерирует случайное трёхзначное число и выводит само число, сумму цифр ,произведение цифр. 0
        0
         0
        0
    Ответы на вопрос
 
        1.
program raf105;
var hour,sec: integer;
begin
write('Введите количество часов: ');
readln(hour);
sec:= hour*60*60;
writeln('Это ',sec,' сек.');
end.
2.
program raf105;
var Xa,Ya,Xb,Yb,k: real;
begin
write('Введите координаты первой точки (Х и Y): ');
readln(Xa,Ya);
write('Введите координаты второй точки (Х и Y): ');
readln(Xb,Yb);
k:= (Yb-Ya/Xb-Xa);
writeln('Угловой коэффициент: ',k:0:2);
end.
3.
program raf105;
var abc,a,b,c,sum,pro: integer;
begin
abc:= random(100,999);
a:= abc div 100;
b:= (abc div 10) mod 10;
c:= abc mod 10;
sum:= a+b+c;
pro:= a*b*c;
writeln('Число ',abc);
writeln('Сумма цифр: ',sum);
writeln('Произведение цифр: ',pro);
end.
PascalABC 3.4.2
 0
                    0
                     0
                    0
                 
            Для решения каждой из данных задач, предлагаю написать программы на языке программирования Python. Ниже приведены решения для каждой задачи:
- Программа для подсчета количества секунд в часе:
pythondef hours_to_seconds(hours):
    return hours * 3600
try:
    hours_input = int(input("Введите количество часов: "))
    seconds = hours_to_seconds(hours_input)
    print(f"{hours_input} час(ов) равно {seconds} секунд")
except ValueError:
    print("Ошибка ввода. Пожалуйста, введите целое число часов.")
- Программа для вычисления углового коэффициента прямой:
pythondef slope(x1, y1, x2, y2):
    return (y2 - y1) / (x2 - x1)
try:
    x1 = int(input("Введите координату x точки A: "))
    y1 = int(input("Введите координату y точки A: "))
    x2 = int(input("Введите координату x точки B: "))
    y2 = int(input("Введите координату y точки B: "))
    k = slope(x1, y1, x2, y2)
    print(f"Угловой коэффициент прямой, проходящей через точки A и B, равен {k:.2f}")
except ValueError:
    print("Ошибка ввода. Пожалуйста, введите целочисленные значения координат.")
except ZeroDivisionError:
    print("Ошибка: деление на ноль. Обе точки должны иметь различные значения x.")
- Программа для генерации случайного трехзначного числа и вывода суммы и произведения его цифр:
pythonimport random
def sum_and_product_of_digits(number):
    num_str = str(number)
    digit_sum = sum(int(digit) for digit in num_str)
    digit_product = 1
    for digit in num_str:
        digit_product *= int(digit)
    return digit_sum, digit_product
try:
    random_number = random.randint(100, 999)
    print(f"Сгенерированное трехзначное число: {random_number}")
    
    sum_digits, product_digits = sum_and_product_of_digits(random_number)
    print(f"Сумма цифр числа: {sum_digits}")
    print(f"Произведение цифр числа: {product_digits}")
except ValueError:
    print("Произошла ошибка при генерации случайного числа.")
Обратите внимание, что программы будут выполняться до тех пор, пока пользователь не введет корректные значения. Также обратите внимание на использование целочисленного деления в первой программе и на проверку деления на ноль во второй программе для предотвращения ошибок.
 0
                    0
                     0
                    0
                Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
- 
			Математика 
- 
			Литература 
- 
			Алгебра 
- 
			Русский язык 
- 
			Геометрия 
- 
			Английский язык 
- 
			Химия 
- 
			Физика 
- 
			Биология 
- 
			Другие предметы 
- 
			История 
- 
			Обществознание 
- 
			Окружающий мир 
- 
			География 
- 
			Українська мова 
- 
			Информатика 
- 
			Українська література 
- 
			Қазақ тiлi 
- 
			Экономика 
- 
			Музыка 
- 
			Право 
- 
			Беларуская мова 
- 
			Французский язык 
- 
			Немецкий язык 
- 
			МХК 
- 
			ОБЖ 
- 
			Психология 
- 
			Физкультура и спорт 
- 
			Астрономия 
- 
			Кыргыз тили 
- 
			Оʻzbek tili 
 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			