ПРОГРАММИСТЫ ПОМОГИТЕ!!! (program pr1) !!! Паскаль. Составить программу: Данно трехзначное число
(например 4 5 6). Получить число, в котором цифры стоят в обратном порядке (6 5 4) Ответы на вопрос
Ответ:
uses
Math;
var
n, r, i, d: Integer;
begin
Write ('Введите трехзначное число: ');
ReadLn (n);
r := 0;
d := 100;
if (n >= 100) and (n <= 999) then begin
for i := 1 to 3 do begin
r := r + (n mod 10) * d;
n := n div 10;
d := d div 10;
end;
WriteLn ('Результат = ', r);
end else
WriteLn ('Это не трехзначное число');
ReadLn;
end.
Объяснение:
для 3 цифр в цикле выделяются единицы, десятки, сотни.
умножается на d: в цикле меняется 100, 10, 1
результат суммируется в r
Конечно, я могу помочь вам составить программу на языке Паскаль, которая изменит порядок цифр трехзначного числа на обратный. Вот пример такой программы:
pascalprogram ReverseDigits; var number, reversedNumber: Integer; digit1, digit2, digit3: Integer; begin // Введите трехзначное число WriteLn('Введите трехзначное число:'); ReadLn(number); // Извлечение цифр digit1 := number div 100; digit2 := (number div 10) mod 10; digit3 := number mod 10; // Формирование числа с обратным порядком цифр reversedNumber := digit3 * 100 + digit2 * 10 + digit1; // Вывод результата WriteLn('Число с обратным порядком цифр:', reversedNumber); end.
Программа запрашивает у пользователя трехзначное число, затем извлекает каждую цифру из этого числа. Затем она формирует новое число, переставляя цифры в обратном порядке. Наконец, программа выводит полученное число с обратным порядком цифр.
Убедитесь, что вы используете среду разработки, которая поддерживает язык Паскаль, чтобы скомпилировать и запустить эту программу.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
