Вопрос задан 17.07.2023 в 07:46. Предмет Информатика. Спрашивает Иванов Кирилл.

Написать программу на языке с++, которая вычисляет произведение отрицательных чисел среди четырех

заданных. После чего сообщает - является ли полученное произведение отрицательным или положительным
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Бохан Богдан.

Ответ:

#include <iostream>

using namespace std;

int main()

{

 int a[4];

 int i, p;

 setlocale(LC_ALL, "russian");

 cout << "Введите четыре числа: ";

 for (i = 0; i < 4; i++) {

   cin >> a[i];

 }

 p = 1;

 for (i = 0; i < 4; i++) {

   p *= a[i];

 }

 if (p > 0)

   cout << "\nПроизведение положительно";

 else if (p < 0)

   cout << "\nПроизведение отрицательно";

 else

   cout << "\nПроизведение равно 0";

}

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Вот пример программы на языке C++, который вычисляет произведение отрицательных чисел из четырех заданных и сообщает, является ли полученное произведение отрицательным или положительным:

cpp
#include <iostream> int main() { int num1, num2, num3, num4; std::cout << "Введите четыре числа: "; std::cin >> num1 >> num2 >> num3 >> num4; int negativeProduct = 1; if (num1 < 0) negativeProduct *= num1; if (num2 < 0) negativeProduct *= num2; if (num3 < 0) negativeProduct *= num3; if (num4 < 0) negativeProduct *= num4; if (negativeProduct < 0) std::cout << "Полученное произведение отрицательное." << std::endl; else if (negativeProduct > 0) std::cout << "Полученное произведение положительное." << std::endl; else std::cout << "Нет отрицательных чисел для вычисления произведения." << std::endl; return 0; }

Программа запрашивает у пользователя четыре числа и сохраняет их в переменные num1, num2, num3 и num4. Затем используется переменная negativeProduct, чтобы накопить произведение отрицательных чисел. Если число отрицательное, оно умножается на текущее значение negativeProduct. После вычисления произведения программа проверяет значение negativeProduct и выводит соответствующее сообщение о том, является ли произведение отрицательным, положительным или нет отрицательных чисел для вычисления произведения.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос