1) Перепишите программу в тетрадь var a:array[1..200] of integer; i,n,p,k: integer; begin p:=20;
n:=0; randomize; for i:1 to 200 do a[i]:=random(100)-50; for i:=1 to 200 do write(a[i],' '); writeln; for i:=1 to 200 do if a[i]=p then begin writeln('a[',i,']=',a[i]); n:=n+1; end; writeln; writeln(n); end. 2) Напишите программу в PascalABC. 3) Ответьте письменно на вопросы. Запишите ответы в тетрадь. 3.1. Сколько элементов в массиве? 3.2. Какой фрагмент программы отвечает за запись элементов массива в памяти компьютера? 3.3. В каких пределах целых чисел могут находиться элементы массива? 3.4. Для чего в операторе вывода напечатано ' '? 4) Ответьте письменно на вопросы. Записать ответы в тетрадь. 4.1. Что программа выводит на экран оператором writeln('a[',i,']=',a[i]);? 4.2. Для чего нужна переменная n? 4.3. Какая переменная лишняя? 4.4. Что программа выводит на экран оператором writeln(n);? 5) Измените код программы так, чтобы программа находила и считала количество элементов равных 0 среди 300 элементов целочисленного массива, значение которого расположены между -20 и 20. Написать программу в PascalABC.Ответы на вопрос
Ответ:
3.1. 200
3.2. for i:1 to 200 do a[i]:=random(100)-50;
3.3. (т.к 4 байта)
либо -50 ... 50 (рандом)
3.4. Чтобы значения не "склеивались", т.к было расстояние между элементами
4.1. a[номер элемента] = значение элемента "перенос строки"
4.2. Для подсчета количества элементов равных 20
4.3. k - она объявлена, но не используется
4.4. Количество элементов равных 20
5.
var
a:array[1..300] of integer;
i,n,p,k: integer;
begin
p:=0;
n:=0;
randomize;
for i:1 to 300 do
a[i]:=random(40)-20;
for i:=1 to 300 do
write(a[i],' ');
writeln;
for i:=1 to 300 do
if a[i]=p then
begin
writeln('a[',i,']=',a[i]);
n:=n+1;
end;
writeln;
writeln(n);
end.
ꟷꟷꟷꟷꟷꟷ
Не забывайте сказать "Спасибо"! и, если ответ удовлетворил, то выберите его как "Лучший"
Бодрого настроения и добра!
Успехов в учебе!
- Вот переписанная программа в PascalABC:
pascalvar a: array[1..200] of integer; i, n, p, k: integer; begin p := 20; n := 0; randomize; for i := 1 to 200 do a[i] := random(100) - 50; for i := 1 to 200 do write(a[i], ' '); writeln; for i := 1 to 200 do if a[i] = p then begin writeln('a[', i, '] = ', a[i]); n := n + 1; end; writeln; writeln(n); end.
- Написанная программа в PascalABC:
pascalprogram CountOccurrences; var a: array[1..300] of integer; i, count: integer; begin count := 0; randomize; for i := 1 to 300 do a[i] := random(41) - 20; for i := 1 to 300 do if a[i] = 0 then count := count + 1; writeln('Количество элементов равных 0:', count); end.
- Ответы на вопросы:
3.1. В первоначальной программе массив a содержит 200 элементов.
3.2. Фрагмент программы, отвечающий за запись элементов массива в память компьютера, следующий:
pascalfor i := 1 to 200 do a[i] := random(100) - 50;
3.3. Элементы массива могут находиться в пределах от -50 до 49, так как значения, возвращаемые функцией random(100), находятся в диапазоне от 0 до 99, а затем мы вычитаем 50.
3.4. В операторе вывода ' ' используется для разделения элементов массива при их выводе на экран, чтобы они были более читаемыми.
- Ответы на вопросы:
4.1. Программа выводит на экран значение элемента массива a[i] и его индекс: 'a[', i, '] = ', a[i].
4.2. Переменная n используется для подсчета количества элементов массива, равных значению p.
4.3. Лишней переменной является переменная k, так как она не используется в программе.
4.4. Программа выводит на экран значение переменной n, которая содержит количество элементов массива, равных значению p.
- Вот измененный код программы, который находит и подсчитывает количество элементов, равных 0, среди 300 элементов целочисленного массива, значения которого находятся в диапазоне от -20 до 20:
pascalprogram CountZeroOccurrences; var a: array[1..300] of integer; i, count: integer; begin count := 0; randomize; for i := 1 to 300 do a[i] := random(41) - 20; for i := 1 to 300 do if a[i] = 0 then count := count + 1; writeln('Количество элементов равных 0:', count); end.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
