Вопрос задан 14.07.2023 в 05:53. Предмет Информатика. Спрашивает Ткачук Влад.

Python, пожалуйста!) Уровень E. Напишите программу, которая получает с клавиатуры натуральное

число и определяет, есть ли в его десятичной записи две одинаковые цифры, стоящие рядом.
0 1
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Макаренко Артем.

Ответ:

some_num = input()  

splited_num = list(some_num)

isSameNumNear = False

for index in range(len(splited_num)-1):

   if splited_num[index] == splited_num[index+1]: isSameNumNear = True  

print('2 цифры идут подряд' if isSameNumNear else 'Все цифры разные')


0 0
Отвечает Виницких Лиза.

Ответ:

Если я правильно понял:

Объяснение:

n=input()

for i in range(0, len(n)-1):

  if n[i]==n[i+1]:

     print("YES")

     exit()

P.S. Отпиши если не работает

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот программа на Python, которая выполняет указанную задачу:

python
def has_adjacent_digits(number): num_str = str(number) for i in range(len(num_str) - 1): if num_str[i] == num_str[i + 1]: return True return False def main(): try: n = int(input("Введите натуральное число: ")) if n <= 0: print("Ошибка: введенное число должно быть натуральным.") return if has_adjacent_digits(n): print("В числе есть две одинаковые цифры, стоящие рядом.") else: print("В числе нет двух одинаковых цифр, стоящих рядом.") except ValueError: print("Ошибка: введенное значение не является целым числом.") if __name__ == "__main__": main()

Пользователь вводит натуральное число, и программа проверяет, есть ли в его десятичной записи две одинаковые цифры, стоящие рядом. Если такие цифры есть, то выводится сообщение "В числе есть две одинаковые цифры, стоящие рядом." иначе "В числе нет двух одинаковых цифр, стоящих рядом."

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос