Вопрос задан 14.07.2023 в 01:44. Предмет Информатика. Спрашивает Доманский Данила.

Задача 5 Написать программу, принимающую 1 аргумент — число от 0 до 200, и возвращающую True,

если оно простое, и False - иначе. на Python
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Петров Иван.

from math import sqrt, trunc

def isPrime(n):

   if (n < 2):

       return False

   for i in range(2, trunc(sqrt(n) + 1)):

       if n % i == 0:

           return False

   return True

print(isPrime( int(input()) ))

0 0
Отвечает Кот Лиза.

Ответ:

#Сама функция

def IsPrime(number):

   if number is 1: return False

   for i in range(2, number):

       if number % i == 0: return False  

   return True

#Вызов

print(IsPrime(int(input())))

Объяснение:

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно! Вот пример программы на языке Python, которая проверяет, является ли заданное число простым:

python
def is_prime(number): if number < 2: return False for i in range(2, int(number ** 0.5) + 1): if number % i == 0: return False return True # Пример использования функции num = int(input("Введите число от 0 до 200: ")) result = is_prime(num) print(result)

В данной программе используется функция is_prime, которая принимает число в качестве аргумента и возвращает True, если число простое, и False в противном случае.

Алгоритм проверки основан на том, что простое число не делится ни на одно число, кроме 1 и самого себя. В цикле мы проверяем, делится ли число на какое-либо число в диапазоне от 2 до корня из числа (плюс один). Если делится, то число не является простым и возвращается False. Если цикл завершился без делителей, то число простое и возвращается True.

Программа принимает число от пользователя и выводит результат проверки на экран.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос