Вопрос задан 13.07.2023 в 12:13. Предмет Информатика. Спрашивает Сапарғали Эльвира.

Задание на Паскале: a, b, c – стороны предполагаемого треугольника. Требуется сравнить длину

каждого отрезка с суммой двух других. Если хотя бы в одном случае отрезок окажется больше суммы двух других, то треугольника с такими сторонами не существует. Помогите, пожалуйста
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Громов Жека.

Пожалуйста)

program such_treug;

var

a,b,c:real;

begin

read(a,b,c);

if (a+b>c)and(a+c>b)and(b+c>a) then

write('Треугольрик существует')

else

write('Треугольник не существует')

end.

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, я могу помочь вам написать программу на языке Паскаль для выполнения этой задачи. Вот пример кода:

pascal
program TriangleCheck; var a, b, c: Integer; begin writeln('Введите длины сторон треугольника:'); readln(a, b, c); if (a < b + c) and (b < a + c) and (c < a + b) then writeln('Треугольник с такими сторонами существует.') else writeln('Треугольник с такими сторонами не существует.'); readln; end.

В этом примере программа запрашивает у пользователя длины сторон треугольника (a, b и c), а затем проверяет условие существования треугольника. Если каждая сторона меньше суммы двух других сторон, то выводится сообщение "Треугольник с такими сторонами существует." В противном случае выводится сообщение "Треугольник с такими сторонами не существует."

Пожалуйста, обратите внимание, что этот пример кода предназначен для языка программирования Паскаль и может быть выполнен в среде, поддерживающей этот язык.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос