Вопрос задан 13.07.2023 в 10:05.
Предмет Информатика.
Спрашивает Надолинный Олег.
Помогите, пожалуйста, нужно составить программу в паскале Заранее спасибо) Задание: Найдите
среднее арифметическое элементов массива, заполненного случайными числами от 6 до 21. Размерность массива вводится с клавиатуры. Вывести на экран все элементы.Ответы на вопрос
Отвечает Кайдарова Камилла.
PascalABC.Net
Varian 1:
- begin
- var n := ReadInteger('Введите размер массива');
- var a := ArrRandom(n, 6, 21);
- Print(a, 'Srednee: ', a.Average);
- end.
Varian 2:
- var
- f: array[1..100] of integer;
- i, sum, N: integer;
- srednee: real;
- begin
- Writeln('Введите размер массива: ');
- Read(N);
- sum := 0;
- randomize;
- for i := 1 to N do
- begin
- f[i] := random(6, 21);
- write(f[i], ' ');
- sum := sum + f[i];
- end;
- srednee := sum / n;
- writeln('Srednee: ', srednee:3:3);
- end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, я помогу вам составить программу на языке Паскаль для нахождения среднего арифметического элементов массива и вывода всех элементов на экран. Ниже приведен пример программы:
pascalprogram AverageArray; const MIN_VALUE = 6; MAX_VALUE = 21; var arr: array of Integer; size, i: Integer; sum, average: Real; begin // Ввод размерности массива Write('Введите размерность массива: '); ReadLn(size); // Выделяем память под массив SetLength(arr, size); // Заполняем массив случайными числами от MIN_VALUE до MAX_VALUE Randomize; for i := 0 to size - 1 do begin arr[i] := Random(MAX_VALUE - MIN_VALUE + 1) + MIN_VALUE; end; // Выводим на экран все элементы массива WriteLn('Элементы массива:'); for i := 0 to size - 1 do begin Write(arr[i], ' '); end; WriteLn; // Находим сумму всех элементов sum := 0; for i := 0 to size - 1 do begin sum := sum + arr[i]; end; // Находим среднее арифметическое if size > 0 then average := sum / size else average := 0; // Выводим среднее арифметическое на экран WriteLn('Среднее арифметическое: ', average:0:2); end.
Программа сначала запрашивает размерность массива, затем заполняет его случайными числами в диапазоне от 6 до 21. После этого выводит все элементы на экран и находит среднее арифметическое, выводя результат также на экран.
Похожие вопросы
Информатика 25
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
