
СРОЧНО НУЖНА ПОМОЩЬ Т-Т Нужно составить программу в паскале. Дан массив из 20
элементов,заполненный случайными числами от -15 до 30. Нужно найти номера максимального и минимального элементов этого массива.

Ответы на вопрос

Ответ:
1.
program z1;
const n=20;
var a:array [1..n] of integer;
i,maxi,mini:integer;
begin
maxi:=1;
mini:=1;
write('Массив А: ');
for i:=1 to n do
begin
a[i]:=random(46)-15;
if a[i] > a[maxi] then maxi:=i;
if a[i] < a[mini] then mini:=i;
write(a[i],' ')
end;
writeln;
writeln('Максимальный элемент a[',maxi,'] = ',a[maxi]);
writeln('Минимальный элемент a[',mini,'] = ',a[mini])
end.
2.
program z1;
const n=20;
var a:array [1..n] of integer;
i,max,min:integer;
begin
max:=-15;
min:=30;
write('Массив А: ');
for i:=1 to n do
begin
a[i]:=random(46)-15;
if a[i] > max then max:=a[i];
if a[i] < min then min:=a[i];
write(a[i],' ')
end;
writeln;
for i:=1 to n do
begin
if a[i]=max then writeln('Максимальный элемент a[',i,'] = ',a[i]);
if a[i]=min then writeln('Минимальный элемент a[',i,'] = ',a[i])
end
end.
Объяснение:
1. Не учитывает повтор элементов. Ищет первый максимальный и первый минимальный элементы.
2. Учитывает повтор элементов, но надо точно задавать max и min исходя из диапазона чисел.



Конечно, я могу помочь вам с этой задачей. Вот пример программы на языке Pascal, который находит номера максимального и минимального элементов в массиве:
pascalprogram FindMinMaxIndexes; const N = 20; var arr: array[1..N] of Integer; i, maxIdx, minIdx: Integer; begin { Заполняем массив случайными числами от -15 до 30 } Randomize; for i := 1 to N do arr[i] := Random(46) - 15; { Генерируем числа от 0 до 45 и вычитаем 15 } { Находим номер максимального элемента } maxIdx := 1; for i := 2 to N do if arr[i] > arr[maxIdx] then maxIdx := i; { Находим номер минимального элемента } minIdx := 1; for i := 2 to N do if arr[i] < arr[minIdx] then minIdx := i; { Выводим результаты } WriteLn('Массив:'); for i := 1 to N do Write(arr[i], ' '); WriteLn; WriteLn('Номер максимального элемента: ', maxIdx); WriteLn('Номер минимального элемента: ', minIdx); end.
Эта программа создает массив из 20 случайных чисел от -15 до 30, а затем находит номера максимального и минимального элементов в этом массиве. Надеюсь, это поможет вам решить вашу задачу!


Похожие вопросы
Топ вопросов за вчера в категории Информатика








Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili