Вопрос задан 12.07.2023 в 15:48.
Предмет Информатика.
Спрашивает Старков Сёма.
Составить программу, которая формирует случайным образом массив NxN целых чисел и упорядочивает по
убыванию каждую строку массива. паскальОтветы на вопрос
Отвечает Яковлев Михаил.
===== PascalABC.NET =====
begin
var n := ReadInteger('N =');
var a := MatrRandom(n, n, -99, 99);
a.Println;
for var i := 0 to n - 1 do
a.SetRow(i, a.Row(i).OrderDescending.ToArray);
Writeln;
a.Println
end.

Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Для составления программы на языке Паскаль, которая создает случайный массив NxN целых чисел и упорядочивает каждую строку по убыванию, можно использовать алгоритм сортировки (например, сортировку пузырьком) для каждой строки массива. Вот пример программы на Паскале:
pascalprogram Sort2DArray; const N = 5; // Задаем размерность массива NxN type TArray = array[1..N, 1..N] of integer; var arr: TArray; procedure InitializeArray(var arr: TArray); var i, j: integer; begin randomize; // Инициализируем генератор случайных чисел for i := 1 to N do for j := 1 to N do arr[i, j] := random(100); // Заполняем массив случайными числами от 0 до 99 end; procedure SortRow(var row: array of integer); var i, j, temp: integer; begin for i := 0 to Length(row) - 1 do for j := 0 to Length(row) - 2 - i do begin if row[j] < row[j + 1] then // Переставляем элементы в порядке убывания begin temp := row[j]; row[j] := row[j + 1]; row[j + 1] := temp; end; end; end; procedure Sort2DArray(var arr: TArray); var i: integer; begin for i := 1 to N do SortRow(arr[i]); // Сортируем каждую строку массива по убыванию end; procedure PrintArray(const arr: TArray); var i, j: integer; begin for i := 1 to N do begin for j := 1 to N do write(arr[i, j]:4); writeln; end; end; begin InitializeArray(arr); writeln('Исходный массив:'); PrintArray(arr); Sort2DArray(arr); writeln('Массив с упорядоченными строками по убыванию:'); PrintArray(arr); end.
В этом примере программы используется алгоритм сортировки пузырьком для сортировки каждой строки массива. Вы можете изменить размерность массива, если нужно получить массив другой размерности.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
