Вопрос задан 12.07.2023 в 06:20.
Предмет Информатика.
Спрашивает Александрова Ульяна.
Напишите программу для заполнения массива случайными числами от -40 до 40 и вывод на экран
отрицательных чисел. ПаскальОтветы на вопрос
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно! Вот пример программы на языке Паскаль, которая заполняет массив случайными числами от -40 до 40 и выводит на экран отрицательные числа:
pascalprogram RandomArray; const N = 10; // размер массива var arr: array[1..N] of Integer; i: Integer; begin Randomize; // инициализация генератора случайных чисел // заполняем массив случайными числами от -40 до 40 for i := 1 to N do arr[i] := Random(81) - 40; // выводим отрицательные числа writeln('Отрицательные числа в массиве:'); for i := 1 to N do begin if arr[i] < 0 then writeln(arr[i]); end; readln; end.
Программа создает массив arr размером N и заполняет его случайными числами от -40 до 40 с помощью функции Random. Затем она выводит на экран все отрицательные числа из массива. Вы можете изменить значение N в программе, чтобы задать другой размер массива.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 75
Информатика 35
Информатика 10
Информатика 40
Информатика 22
Информатика 268
Информатика 36
Информатика 29
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
