Напишите программу на языке Pascal: нахождение максимального или минимального элемента в массиве из
10 чисел. Даю очень много баллов.Ответы на вопрос
Ответ:
Вариант, когда массив заполняется случайными числами:
var A: array [1..10] of integer;
var i,max,min: integer;
begin
max:=1;
min:=1;
randomize();
for i:=1 to 10 do
begin
A[i]:=random(100);
write(A[i],' ');
if (A[i]>A[max]) then max:=i;
if (A[i]<A[min]) then min:=i;
end;
writeln();
writeln('Минимальный элемент: ',A[min]);
writeln('максимальный элемент: ',A[max]);
end.
Вариант, когда массив вводится с клавиатуры:
var A: array [1..10] of integer;
var i,max,min: integer;
begin
max:=1;
min:=1;
for i:=1 to 10 do
begin
readln(A[i]);
if (A[i]>A[max]) then max:=i;
if (A[i]<A[min]) then min:=i;
end;
writeln();
writeln('Минимальный элемент: ',A[min]);
writeln('максимальный элемент: ',A[max]);
end.
Конечно, вот программа на языке Pascal для нахождения максимального и минимального элементов в массиве из 10 чисел:
pascalprogram MaxMinArray; const N = 10; var arr: array[1..N] of Integer; i, max, min: Integer; begin writeln('Введите ', N, ' чисел для заполнения массива:'); // Заполнение массива for i := 1 to N do begin write('Число ', i, ': '); readln(arr[i]); end; // Нахождение максимального элемента max := arr[1]; for i := 2 to N do begin if arr[i] > max then max := arr[i]; end; // Нахождение минимального элемента min := arr[1]; for i := 2 to N do begin if arr[i] < min then min := arr[i]; end; writeln('Максимальный элемент: ', max); writeln('Минимальный элемент: ', min); end.
Программа запрашивает у пользователя 10 чисел для заполнения массива и затем находит максимальный и минимальный элементы в этом массиве. Результаты выводятся на экран.
Удачи с выполнением задания! Если у вас возникнут ещё вопросы или нужна дополнительная помощь, не стесняйтесь спрашивать.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
