СРОЧНО ДАМ 50 БАЛЛОВ составьте программу в паскале abs. найти произведение чисел от 1 до n. через
цикл while и repeatОтветы на вопрос
Ответ:
1. while
var i,n: integer;
p: real;
begin
write('Введите число: ');//n<171
read(n);
p:=1;
i:=1;
while i<=n do
begin
p:=p*i;
i:=i+1
end;
write ('Произведение чисел от 1 до ',n,' равно ',p)
end.
2. repeat
var i,n: integer;
p: real;
begin
write('Введите число: ');//n<171
read(n);
p:=1;
i:=1;
repeat
p:=p*i;
i:=i+1
until i>n;
write ('Произведение чисел от 1 до ',n,' равно ',p)
end.
Конечно, вот две программы на языке Паскаль, которые используют циклы while и repeat, чтобы найти произведение чисел от 1 до n.
Программа с использованием цикла while:
pascalprogram ProizvedenieWhile; var n, proizvedenie, i: integer; begin writeln('Введите число n:'); readln(n); proizvedenie := 1; i := 1; while i <= n do begin proizvedenie := proizvedenie * i; i := i + 1; end; writeln('Произведение чисел от 1 до ', n, ' равно ', proizvedenie); end.
Программа с использованием цикла repeat:
pascalprogram ProizvedenieRepeat; var n, proizvedenie, i: integer; begin writeln('Введите число n:'); readln(n); proizvedenie := 1; i := 1; repeat proizvedenie := proizvedenie * i; i := i + 1; until i > n; writeln('Произведение чисел от 1 до ', n, ' равно ', proizvedenie); end.
Обе программы запрашивают у пользователя число n, а затем используют цикл while (в первой программе) или цикл repeat (во второй программе), чтобы вычислить произведение чисел от 1 до n. Результат выводится на экран.
Надеюсь, это помогло! Если у вас есть ещё вопросы, не стесняйтесь задавать.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
