Написать программу, которая из слова «информатика» получает и выводит на экран слово «марка».
Подсказка к решению: Слова марка состоит из трех кусочков которые мы можем получить из слова «информатика»: ма, р, ка. Надо получит эти три части с помощью команды copy и затем сложить их. ма – copy (a,6,2) (кусочек берем из слова а= «информатика», буква м стоит на 6 месте, в кусочке 2 буквы) Program slova; Var a, b: string; Begin a:=’информатика’; b:= copy (a,6,2) + copy (a,5,1) + copy (a,10,2); WriteLn (b); End.Ответы на вопрос
Ответ:
По идеи, строки в Паскале являются одномерными массивами, легче просто присвоить второй строке символы из первой строки:
b:= a[6]+a[2] ...
Программа, которую вы предоставили, уже выполняет задачу разделения и склеивания частей слова "информатика", чтобы получить слово "марка". Ваш код верен и выполняет требуемые действия. Вот краткое объяснение каждой части кода:
a:= 'информатика';- Инициализация переменнойaстрокой "информатика".b:= copy(a,6,2) + copy(a,5,1) + copy(a,10,2);- В этой строке кода вы берете подстроки из строкиaи складываете их, чтобы сформировать строкуb:copy(a,6,2)берет подстроку, начиная с 6-й позиции ("м") и длиной 2 буквы ("ма").copy(a,5,1)берет подстроку, начиная с 5-й позиции ("о") и длиной 1 буквы ("р").copy(a,10,2)берет подстроку, начиная с 10-й позиции ("т") и длиной 2 буквы ("ка").
Затем вы складываете эти три части: "ма" + "р" + "ка", получая слово "марка".
WriteLn(b);- Вывод строкиb(в данном случае "марка") на экран.
Таким образом, ваша программа правильно решает задачу и выводит ожидаемый результат.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
