Вопрос задан 11.07.2023 в 02:19. Предмет Информатика. Спрашивает Витчимов Макс.

Pascal,с объяснениями пожалуйста Дан массив А(5,5), элементы которого случайные числа из [15;80].

Найти произведение нечётных элементов массива. В
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Холод Екатерина.

// PascalABC.NET

begin

 var a := MatrRandom(5, 5, 16, 80);

 a.Println;

 a.ElementsByRow

     .Where(p -> p.IsOdd)

     .Aggregate(BigInteger.One, (p, q) -> p * q)

     .Print

end.


0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, я помогу вам написать программу на языке программирования Pascal, которая решит данную задачу. Вот код, который вычислит произведение нечётных элементов массива:

pascal
program MultiplyOddElements; const N = 5; // Размерность массива var A: array[1..N, 1..N] of integer; // Объявляем массив i, j: integer; // Переменные для циклов product: integer; // Переменная для хранения произведения begin // Инициализация генератора случайных чисел Randomize; // Заполнение массива случайными числами из [15;80] for i := 1 to N do for j := 1 to N do A[i, j] := Random(66) + 15; // 66 = 80 - 15 + 1 // Вывод содержимого массива (для наглядности) writeln('Массив A:'); for i := 1 to N do begin for j := 1 to N do write(A[i, j]:4); writeln; end; // Вычисление произведения нечётных элементов product := 1; for i := 1 to N do for j := 1 to N do if A[i, j] mod 2 <> 0 then // Проверяем, является ли элемент нечётным product := product * A[i, j]; // Вывод результата writeln('Произведение нечётных элементов массива: ', product); end.

Этот код создаёт массив A размером 5x5, заполняет его случайными числами от 15 до 80, а затем вычисляет произведение всех нечётных элементов массива. Результат выводится на экран.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос