 
СРОЧНО, ДАЮ 65 БАЛЛОВ!!!! Написать программы для python. 1.Написать программу, которая находит
сумму от 1 до N чисел. 2.Дано несколько чисел. Вычислите их произведение. Сначала вводите количество чисел N, затем вводится ровно N целых чисел. 0
        0
         0
        0
    Ответы на вопрос
 
        # Python 3.x
# 1.
# Полагаю, N нам уже должен быть дан? Для теста возьмем конкретный.
N=9999
digits=[digit for digit in range(1, N + 1)]
sumary=sum(digits)
print("#1. Result: ", sumary)
# 2.
# Если ваш учитель нормальный, то на зависимость от стандартной библиотеки ругаться не будет.
import numpy
total=input("Numbers amount: ")
try: total=int(total)
except: raise Warning("Enter INTEGER only!")
digits=[int(input(f"Enter #{i + 1} digit: ")) for i in range(total)]
produce=numpy.prod(digits)
print("#2. Result: ", produce)
 0
                    0
                     0
                    0
                 
            Конечно, я могу помочь вам написать программы на языке Python. Вот две программы, которые решают ваши задачи:
- Программа для нахождения суммы чисел от 1 до N:
pythonN = int(input("Введите число N: "))
sum = 0
for i in range(1, N+1):
    sum += i
print("Сумма чисел от 1 до", N, "равна", sum)
- Программа для вычисления произведения нескольких чисел:
pythonN = int(input("Введите количество чисел: "))
product = 1
for i in range(N):
    num = int(input("Введите число: "))
    product *= num
print("Произведение чисел равно", product)
Просто скопируйте каждую программу в отдельный файл с расширением ".py" и запустите его в среде разработки Python или в командной строке. Обратите внимание, что я предполагаю, что вводимые значения будут целыми числами.
 0
                    0
                     0
                    0
                Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
- 
			Математика 
- 
			Литература 
- 
			Алгебра 
- 
			Русский язык 
- 
			Геометрия 
- 
			Английский язык 
- 
			Химия 
- 
			Физика 
- 
			Биология 
- 
			Другие предметы 
- 
			История 
- 
			Обществознание 
- 
			Окружающий мир 
- 
			География 
- 
			Українська мова 
- 
			Информатика 
- 
			Українська література 
- 
			Қазақ тiлi 
- 
			Экономика 
- 
			Музыка 
- 
			Право 
- 
			Беларуская мова 
- 
			Французский язык 
- 
			Немецкий язык 
- 
			МХК 
- 
			ОБЖ 
- 
			Психология 
- 
			Физкультура и спорт 
- 
			Астрономия 
- 
			Кыргыз тили 
- 
			Оʻzbek tili 
 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			