Вопрос задан 10.07.2023 в 18:38.
Предмет Информатика.
Спрашивает Дёмин Захар.
Составьте программу подсчета таких строк двухмерного массива A(P,Q), что суммы элементов этих строк
положительны. (Паскаль!)Ответы на вопрос
Отвечает Милетич Ростислав.
===== PascalABC.NET =====
begin
var (строк, столбцов) := ReadInteger2('Укажите P и Q:');
var (от, до) := (-99, 99);
var массив := MatrRandom(строк, столбцов, от, до);
массив.Println;
массив.Rows
.Select(строка -> строка.Sum)
.Count(сумма -> сумма > 0)
end.

Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот программа на языке Pascal, которая подсчитывает количество строк двумерного массива A(P,Q), суммы элементов которых положительны:
pascalprogram CountPositiveSumRows; const P = 5; // Количество строк массива A Q = 5; // Количество столбцов массива A type TArray = array[1..P, 1..Q] of integer; var A: TArray; count: integer; procedure InitializeArray(var A: TArray); var i, j: integer; begin // Здесь можно инициализировать массив A случайными значениями или ввести значения вручную // В данном примере, массив будет заполнен случайными числами от -10 до 10 for i := 1 to P do for j := 1 to Q do A[i, j] := Random(21) - 10; // Генерация случайного числа от -10 до 10 end; function RowSumPositive(row: integer; var A: TArray): boolean; var j, sum: integer; begin sum := 0; for j := 1 to Q do sum := sum + A[row, j]; RowSumPositive := sum > 0; end; begin randomize; // Инициализация генератора случайных чисел InitializeArray(A); count := 0; for i := 1 to P do if RowSumPositive(i, A) then Inc(count); writeln('Массив A:'); for i := 1 to P do begin for j := 1 to Q do write(A[i, j]:4); writeln; end; writeln('Количество строк с положительной суммой элементов: ', count); end.
Обратите внимание, что в этой программе массив A(P,Q) инициализируется случайными числами от -10 до 10. Вы можете изменить эту инициализацию по своему усмотрению. Программа сначала заполняет массив A случайными числами, затем подсчитывает количество строк, суммы элементов которых положительны, и выводит результат.
Похожие вопросы
Информатика 26
Информатика 330
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
