Вопрос задан 10.07.2023 в 15:31.
Предмет Информатика.
Спрашивает Сорока Микола.
Составьте программу которая вычисли наименьшее из 20 чисел! На Паскале.
Ответы на вопрос
Отвечает Монгулов Найыр.
Ответ:
Числа задаются случайным образом на случайном промежутке. Если требовался ввод с клавиатуры, напишите об этом.
var a: array[1..20] of integer;
var i,min: integer;
begin
randomize();
min:=1;
for i:=1 to 20 do
begin
a[i]:=random(-100,100);
write(a[i],' ');
if (a[i]<a[min]) then min:=i;
end;
writeln();
writeln('Меньшее из 20 чисел равно ',a[min]);
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот пример программы на языке Паскаль, которая вычислит наименьшее из 20 чисел:
pascalprogram FindMinimum; var numbers: array [1..20] of Integer; i, minimum: Integer; begin writeln('Введите 20 чисел:'); for i := 1 to 20 do begin write('Число ', i, ': '); readln(numbers[i]); end; minimum := numbers[1]; for i := 2 to 20 do begin if numbers[i] < minimum then minimum := numbers[i]; end; writeln('Наименьшее число: ', minimum); end.
Программа просит пользователя ввести 20 чисел, сохраняет их в массиве numbers, а затем проходит по массиву и находит наименьшее число. В конце выводится результат.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 35
Информатика 54
Информатика 12
Информатика 266
Информатика 25
Информатика 33
Информатика 16
Информатика 10
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
