Вопрос задан 10.07.2023 в 13:55. Предмет Информатика. Спрашивает Заяц Диана.

2. Задача на While. Написать программу, которая считает сумму случайных чисел в диапазоне от-50

до 50 до тех пор, пока случайное число не выпадет равным 10. Полученную сумму вывести на экран монитора 3. Написать программу, которая перебирает все трехзначные числа и выводит на экран только те, которые кратны 5. Если можно пожалуйста решите без сложных команд) по типу как первое решено 1. (Задача на if) Запросить радиус круга R и сторону квадрата А. Определить, поместится ли круг в квадрате. Круг поместится в квадрате, если диаметр круга меньше или равен стороне квадрата. a=int(input('введите сторону квадрата')) r=int(input('введите радиус окружности')) d=2*r if d<=a: print('поместится') else: print ('не поместится')
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Мухамедшаев Ринат.

2)

import random

k = 0

while True:

   x = random.randint(-50, 50)

   if x == 10:

       break

   else:

       k += x

print(k)

3)

for i in range(100, 1000, 5):

   print(i, end = ' ')

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, я помогу вам с решением задач на While.

  1. Программа, которая считает сумму случайных чисел в диапазоне от -50 до 50 до тех пор, пока случайное число не станет равным 10:
python
import random sum_of_numbers = 0 while True: random_number = random.randint(-50, 50) sum_of_numbers += random_number if random_number == 10: break print("Сумма случайных чисел до выпадения числа 10:", sum_of_numbers)
  1. Программа, которая перебирает все трехзначные числа и выводит на экран только те, которые кратны 5:
python
for number in range(100, 1000): if number % 5 == 0: print(number)

Это простые программы, не содержащие сложных команд. Первая программа использует цикл while, чтобы суммировать случайные числа, пока не будет получено число 10. Вторая программа использует цикл for для перебора всех трехзначных чисел и выводит только те, которые кратны 5.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос