Вопрос задан 10.07.2023 в 11:09. Предмет Информатика. Спрашивает Волк Света.

в Питоне Напишите программу, которая в последовательности натуральных чисел определяет количество

чисел, кратных 6 и оканчивающихся на 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000. Программа должна вывести одно число: количество чисел, кратных 6 и оканчивающихся на 4.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Кот Тина.

k = 0

N = int(input('Введите количество чисел в последовательности: '))

for i in range(N):

   a = int(input())

   if a % 10 == 4 and a % 6 == 0:

       k+=1

print(k)

0 0
Отвечает Бибикова Диана.

Ответ: Считываем первое число(n), чтобы определить, до какого момента должен продолжаться цикл. Создаем переменную sum, чтобы хранить найденное количество чисел, удовлетворяющих условию. Запускаем цикл, считываем число, если последняя цифра - 4 (проверяем при помощи получения остатка от деления на 10) и число делится на 6 (проверяем при помощи получения остатка от деления на 6), то добавляем к в переменную sum 1.

n = int(input())

sum = 0

for i in range(0, n):

  current = int(input())

  if current % 10 == 4 and current % 6 == 0:

      sum += 1

print(sum)

Объяснение: n = int(input())

sum = 0

for i in range(0, n):

  current = int(input())

  if current % 10 == 4 and current % 6 == 0:

      sum += 1

print(sum)

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот пример программы на Python, которая выполняет задачу:

python
def main(): n = int(input("Введите количество чисел: ")) count = 0 for _ in range(n): num = int(input("Введите число: ")) if num % 6 == 0 and num % 10 == 4: count += 1 print("Количество чисел, кратных 6 и оканчивающихся на 4:", count) if __name__ == "__main__": main()

Вы можете скопировать этот код в свой редактор Python и запустить. Программа будет запрашивать количество чисел в последовательности, а затем по очереди вводить сами числа. После ввода всех чисел, программа выведет количество чисел, которые соответствуют условиям (кратные 6 и оканчиваются на 4).

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос