Вопрос задан 10.07.2023 в 09:35. Предмет Информатика. Спрашивает Bilovus Diana.

Написать программу:из интервала от "а" до "б" целых чисел вывести в одну строку с разделителем "."

числа кратные 5. В случае, если а больше б вывести надпись "Ошибка"​
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Солодухина Ангелина.

Ответ:

Могу только на питоне. (Если надо на другом языке программирования, попробуй через какой-нибудь онлайн конвертер кода)

a = int(input())

b = int(input())

if a > b:

   print('Ошибка')

else:

   for i in range(a, b + 1):

       c = int(input())

       if c % 5 == 0:

           print(c, end='.')

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот пример программы на языке Python, которая выполняет указанные вами действия:

python
def main(): a = int(input("Введите начальное число (a): ")) b = int(input("Введите конечное число (b): ")) if a > b: print("Ошибка") return result = [] for num in range(a, b + 1): if num % 5 == 0: result.append(str(num)) if result: print(".".join(result)) else: print("В указанном интервале нет чисел, кратных 5") if __name__ == "__main__": main()

Скопируйте этот код в файл с расширением ".py" и запустите его. Программа попросит вас ввести начальное и конечное числа, а затем выведет числа, кратные 5, разделенные точкой, или сообщение "Ошибка", если начальное число больше конечного числа.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос