Используя программу Паскаль написать программу, находящую сумму 20 любых чисел Сделайте плиз
качественно. Ответы на вопрос
Ответ:
Program z1;
var a1,a2,a3,a4,a5,a6,a7,a8,a9,a10,a11,a12,a13,a14,a15,a16,a17,a18,a19,a20,s:int64;
begin
readln(a1);
readln(a2);
readln(a3);
readln(a4);
readln(a5);
readln(a6);
readln(a7);
readln(a8);
readln(a9);
readln(a10);
readln(a11);
readln(a12);
readln(a13);
readln(a14);
readln(a15);
readln(a16);
readln(a17);
readln(a18);
readln(a19);
readln(a20);
s:=a1+a2+a3+a4+a5+a6+a7+a8+a9+a10+a11+a12+A13+a14+a15+a16+a17+a18+a19+a20;
writeln(s);
end.
Объяснение:
Конечно, вот пример программы на языке Паскаль, которая считывает 20 чисел с клавиатуры и выводит их сумму:
pascalprogram SumOfNumbers; var i, number, sum: integer; begin sum := 0; // Инициализируем сумму нулевым значением writeln('Введите 20 чисел:'); for i := 1 to 20 do begin write('Число ', i, ': '); readln(number); sum := sum + number; // Добавляем введенное число к сумме end; writeln('Сумма введенных чисел: ', sum); end.
Скопируйте этот код в вашу среду разработки для Pascal (например, Turbo Pascal или Free Pascal), чтобы выполнить программу. Она будет запрашивать ввод 20 чисел и после ввода всех чисел выведет их сумму.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
