Вопрос задан 09.07.2023 в 18:10.
Предмет Информатика.
Спрашивает Mikashov Daniil.
Помогите решить задачи в Паскале. 1. Напишите программу, которая в последовательности целых чисел
определяет среднее арифметическое отрицательных, оканчивающихся на 1, чисел. Программа получает на вход целые числа, количество которых неизвестно, но последовательность заканчивается числом 0 (0-признак окончания и в последовательность не входит). 2. Напишите программу, которая в последовательности натуральных чисел определяет порядковый номер максимального четного числа. Программа получает на вход количество чисел в последовательности, а затем сами числа. Если в последовательности нет нужных чисел, вывести «не найдено».Ответы на вопрос
Отвечает Соболь Вика.
Ответ:
PascalABC.NET 3.5.1 + .NET Framework 4.7.1
#1
begin
var A := ReadSeqIntegerWhile(p -> p <> 0).ToList;
A.Where(p -> (p < 0) and (abs(p) mod 10 = 1)).Average.Println;
end.
#2
begin
var A := ReadArrInteger(ReadInteger());
var max_even := A.Where(p->p mod 2 = 0).Max;
var max_ind := A.IndexOf(max_even);
if max_ind = -1 then print('Нет') else print(max_ind+1);
end.
Объяснение:
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, я могу помочь вам с написанием программ на Pascal. Вот решения ваших задач:
- Программа для вычисления среднего арифметического отрицательных чисел, оканчивающихся на 1:
pascalprogram AverageNegativeEndingIn1; var num, count, sum: integer; avg: real; begin count := 0; sum := 0; repeat read(num); if (num <> 0) and (num < 0) and (num mod 10 = 1) then begin sum := sum + num; count := count + 1; end; until num = 0; if count > 0 then begin avg := sum / count; writeln('Среднее арифметическое отрицательных чисел, оканчивающихся на 1: ', avg:0:2); end else writeln('Нет подходящих чисел.'); end.
- Программа для определения порядкового номера максимального четного числа:
pascalprogram MaxEvenNumberPosition; var n, num, maxEven, maxEvenPosition, i: integer; begin readln(n); maxEven := -1; // Начальное значение для максимального четного числа maxEvenPosition := -1; // Начальное значение для позиции максимального четного числа for i := 1 to n do begin read(num); if (num mod 2 = 0) and (num > maxEven) then begin maxEven := num; maxEvenPosition := i; end; end; if maxEvenPosition <> -1 then writeln('Порядковый номер максимального четного числа: ', maxEvenPosition) else writeln('Не найдено.'); end.
Просто скопируйте соответствующий код в среду разработки Pascal и выполните программы. Они решат задачи, как описано.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 38
Информатика 45
Информатика 24
Информатика 39
Информатика 16
Информатика 30
Информатика 16
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
