Вопрос задан 09.07.2023 в 07:22.
Предмет Информатика.
Спрашивает Иващенко Валя.
Помогите пожалуйста! Написать программу на языке Паскаль вычисления площади треугольника по трем
сторонам: a, b, c. (Используя формулу Герона)Ответы на вопрос
Отвечает Плысенко Анна.
Ответ:
var
a,b,c,p:real;
begin
read(a,b,c);
p:=(a+b+c)/2;
p:=sqrt(p*(p-a)*(p-b)*(p-c));
writeln('S=',p);
end.
Отвечает Андреева Анастасия.
Ответ:
var
a,b,c,p:real;
begin
read(a,b,c);
p:=(a+b+c)/2;
p:=sqrt(p*(p-a)*(p-b)*(p-c));
writeln('S=',p);
end
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно! Вот пример программы на языке Паскаль для вычисления площади треугольника по трем сторонам (a, b, c) с использованием формулы Герона:
pascalprogram AreaOfTriangle; var a, b, c, s, area: real; begin // Ввод длин сторон треугольника writeln('Введите длины сторон треугольника:'); write('a = '); readln(a); write('b = '); readln(b); write('c = '); readln(c); // Вычисление полупериметра s := (a + b + c) / 2; // Вычисление площади по формуле Герона area := sqrt(s * (s - a) * (s - b) * (s - c)); // Вывод результата writeln('Площадь треугольника: ', area:0:2); end.
Программа запрашивает у пользователя длины сторон треугольника (a, b, c), затем вычисляет полупериметр (s) и площадь треугольника (area) с помощью формулы Герона. Результат выводится на экран.
Обратите внимание, что в данном примере используется встроенная функция sqrt для вычисления квадратного корня.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 31
Информатика 36
Информатика 24
Информатика 43
Информатика 18
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
