Вопрос задан 08.07.2023 в 08:02. Предмет Информатика. Спрашивает Бобровская Даша.

ЗАДАНИЕ °Написать программу на ЯП Pyton: определить, является ли введенное целое число

трехзначным и вывести соответствующее сообщение . ПРИМЕР ВЫПОЛНЕНИЯ ЗАДАНИЯ (другая задача) °Написать программу: определить, является ли введенное целое число двузначным и вывести соответствующее сообщение a=int (input(‘введите целое число’)) If (a>9) and (a<100): print (‘число двузначное’) else: print (‘число не двузначное’) РЕШИТЕ ПОЖАЛУЙСТА
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Сафронова Даша.

Ответ:

Объяснение:

for _ in range(100):

   x = input('Введите число: ')

   if len(x) == 3:

       print('Число трёхзначное')

   else:

       print('Число не трёхзначное')

   ans = input('Продолжить? (Y/N) ')

   if ans == 'Y':

       continue

   else:

       break

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот ваша программа на Python, которая определяет, является ли введенное целое число трехзначным:

python
a = int(input('Введите целое число: ')) if 100 <= a <= 999: print('Число трехзначное') else: print('Число не трехзначное')

Программа просит пользователя ввести целое число, затем проверяет, находится ли это число в диапазоне от 100 до 999 (включительно). Если число удовлетворяет этому условию, выводится сообщение "Число трехзначное", иначе выводится сообщение "Число не трехзначное".

0 0

Похожие вопросы

Последние заданные вопросы в категории Информатика

Задать вопрос