Вопрос задан 08.07.2023 в 00:32.
Предмет Информатика.
Спрашивает Нягин Иван.
Написать в паскале 1 Вывести на экран все двузначные числа в строку через пробел 2 Напишите
программу, которая 7 раз выводит на экран "Черненко Семён" 3 Напишите программу, которая вычисляет сумму всех четных чисел в диапазоне от 1 до n.Ответы на вопрос
Отвечает Федосеев Валера.
Задание 1:
- begin
- for var x := 10 to 99 do print(x);
- end.
Задание 2:
- begin
- loop 7 do println('Черненко Семён')
- end.
Задание 3:
- begin
- (1..ReadInteger('n:')).Where(x->x.isEven).Sum.Print
- end.
Пример работы:

Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот три программы на Pascal, выполняющие указанные задачи:
- Вывести на экран все двузначные числа в строку через пробел:
pascalprogram PrintTwoDigitNumbers; var i: Integer; begin for i := 10 to 99 do Write(i, ' '); end.
- Программа, выводящая "Черненко Семён" 7 раз:
pascalprogram PrintNameSevenTimes; var i: Integer; begin for i := 1 to 7 do writeln('Черненко Семён'); end.
- Программа, вычисляющая сумму всех четных чисел в диапазоне от 1 до n:
pascalprogram SumOfEvenNumbers; var n, i, sum: Integer; begin write('Введите значение n: '); readln(n); sum := 0; for i := 1 to n do begin if i mod 2 = 0 then sum := sum + i; end; writeln('Сумма четных чисел от 1 до ', n, ': ', sum); end.
Примечание: Помните, что эти программы могут быть скомпилированы и выполнены в среде, поддерживающей Pascal.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 35
Информатика 53
Информатика 12
Информатика 263
Информатика 23
Информатика 33
Информатика 15
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
