Вопрос задан 07.07.2023 в 00:18. Предмет Информатика. Спрашивает Борзыкина Анастасия.

Помогите пж На с++Напишите программу, которая в последовательности целых чисел определяет сумму

двузначных нечетных чисел. Программа получает на вход целые числа, количество введенных чисел неизвестно, последовательность чисел заканчивается числом 0 (0-признак окончания ввода, не входит в последовательность).Количество чисел не превышает 1000. Введенные числа по модулю не превышают 30 000.Программа должна вывести одно число: сумму двузначных нечетных чисел.Пример работы программыВходные данные11153090Выходные данные26
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Кузнецова Вера.

Реализация №1

#include <iostream>

using namespace std;

int main()

{

int summ = 0, a;

do

{

cin >> a;

if (a != 0 && a%2==1 && a>=10 && a<=99)

{

summ += a;

}

else

cout << summ << endl;

} while (a != 0);

return 0;

}

Реализация №2 (0 складывается, но на результат не влияет)

#include <iostream>

using namespace std;

int main()

{

int sum=0, a;

cin>>a;

for(sum=0;a!=0;cin>>a)

{

if(a%2==1 && a>=10 && a<=99)

sum+=a;

}

cout<<sum;

return 0;

}



0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот пример программы на C++, которая решает вашу задачу:

cpp
#include <iostream> int main() { int num, sum = 0; while (true) { std::cin >> num; if (num == 0) { break; // Прекращаем ввод при введении 0 } if (num % 2 != 0 && num >= 10 && num <= 99) { sum += num; // Если число нечетное и двузначное, добавляем его к сумме } } std::cout << sum << std::endl; // Выводим сумму двузначных нечетных чисел return 0; }

Вы можете скопировать этот код в свою среду разработки C++ и скомпилировать его, чтобы проверить его работу. Программа будет вводить целые числа до тех пор, пока не будет введено 0. Она будет добавлять к сумме только те числа, которые удовлетворяют условиям: нечетные и двузначные. В конце программа выведет сумму таких чисел.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос