Вопрос задан 06.07.2023 в 22:14. Предмет Информатика. Спрашивает Дроботова Мария.

СРОЧНО, 60 БАЛОВ. Необходимо написать программу, которая выполняет следующие действия: 1.

Запрашивает у пользователя 13 оценок, полученных учащимися за контрольную работу (от 1 до 5), (использовать оператор цикла for или while , запрашивает значит будет использоваться оператор input); 2. Определяет и выводит количество полученных пятёрок, четвёрок, троек, двоек и единиц, (используется оператор для определения if , elif и для вывода оператор print); 3. Выдаёт сообщение о неправильном вводе оценки, например, 0, 6 и т.д. (используется else : print ("такой оценки не существует") .
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Смирнова Юлия.

Ответ:

Как я понял это Python:

ones = 0

tw = 0

th = 0

fo = 0

fi = 0

for i in range(1, 14):

   flag = True

   while flag:

       point = int(input('Введите оценку '))

       if 0 < point <= 5:

           if point == 1:

               ones += 1

           elif point == 2:

               tw += 1

           elif point == 3:

               th += 1

           elif point == 4:

               fo += 1

           elif point == 5:

               fi += 1

           flag = False

       else:

           print('Вы ввели неверную оценку')

print('Получено:\nЕдиниц - ' + str(ones), '\nДвоек - ' + str(tw), '\nТроек - ' + str(th), '\nЧетверок - ' +str(fo), '\nПятерок - ' +str(fi))

   

 

Объяснение:

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот пример программы на Python, который выполняет описанные вами действия:

python
# Создаем переменные для подсчета оценок fives = 0 fours = 0 threes = 0 twos = 0 ones = 0 # Цикл для получения оценок от пользователя for _ in range(13): grade = int(input("Введите оценку от 1 до 5: ")) if grade == 5: fives += 1 elif grade == 4: fours += 1 elif grade == 3: threes += 1 elif grade == 2: twos += 1 elif grade == 1: ones += 1 else: print("Такой оценки не существует") # Выводим результаты подсчета print("Количество пятёрок:", fives) print("Количество четвёрок:", fours) print("Количество троек:", threes) print("Количество двоек:", twos) print("Количество единиц:", ones)

Программа запрашивает 13 оценок у пользователя, затем подсчитывает и выводит количество полученных оценок каждого типа, также выводя сообщение об ошибке, если введена оценка, не попадающая в диапазон от 1 до 5.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос