Вопрос задан 06.07.2023 в 21:29.
Предмет Информатика.
Спрашивает Богданов Дима.
Составить программу (Паскаль): с экрана вводим два значения и сравниваем с константой = 18 1. оба
числа больше или равно 18 2. оба числа меньше 18 3. только одно число больше или равно 18Ответы на вопрос
Отвечает Матасова Женя.
var a,b: real;
begin
readln(a,b);
if (a>=18) and (b>=18) then writeln('1') else if (a<18) and (b<18) then writeln('2') else if (a>=18) or (b>=18) then writeln('3');
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Ниже приведена программа на языке Паскаль, которая сравнивает два введенных числа с константой 18 и выводит соответствующие результаты:
pascalprogram CompareNumbers; var number1, number2: integer; constant: integer = 18; begin writeln('Введите первое число:'); readln(number1); writeln('Введите второе число:'); readln(number2); if (number1 >= constant) and (number2 >= constant) then writeln('Оба числа больше или равны 18') else if (number1 < constant) and (number2 < constant) then writeln('Оба числа меньше 18') else if (number1 >= constant) or (number2 >= constant) then writeln('Только одно число больше или равно 18') else writeln('Ни одно из чисел не соответствует условию'); end.
После запуска программы она будет запрашивать ввод двух чисел с экрана. Затем она сравнивает эти числа с константой 18 и выводит соответствующий результат в зависимости от условий:
- Если оба числа больше или равны 18, программа выводит "Оба числа больше или равны 18".
- Если оба числа меньше 18, программа выводит "Оба числа меньше 18".
- Если только одно число больше или равно 18, программа выводит "Только одно число больше или равно 18".
- Если ни одно из чисел не соответствует указанным условиям, программа выводит "Ни одно из чисел не соответствует условию".
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 33
Информатика 32
Информатика 51
Информатика 94
Информатика 36
Информатика 22
Информатика 36
Информатика 12
Информатика 14
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
