Очень срочно!!!!!!! 5. Напишите программу подсчета количества положительных, количества нулевых и
количества отрицательных элементов массива. Проверьте работу программы на заданном массиве А = {7, 25, 4.5, 0, 17, 61, -10, 0, 1, -4, 22}.Кол-во полож. элементов:Кол-во нулевых элементов:Кол-во отриц. элементов:Ответы на вопрос
        var
a:array [1..11] of real;
i,s1,s2:integer;
begin
s1:=0; s2:=0;
for i:=1 to 11 do
begin
readln(a[i]);
if a[i]>0 then
inc(s1)
else
if a[i]<0 then
inc(s2);
end;
writeln('<0: ', s2);
writeln('>0: ', s1);
writeln('=0: ', i-s1-s2);
end.
            Конечно! Вот пример программы на языке Python для подсчета количества положительных, нулевых и отрицательных элементов массива:
pythonA = [7, 25, 4.5, 0, 17, 61, -10, 0, 1, -4, 22]
positive_count = 0
zero_count = 0
negative_count = 0
for num in A:
    if num > 0:
        positive_count += 1
    elif num == 0:
        zero_count += 1
    else:
        negative_count += 1
print("Кол-во полож. элементов:", positive_count)
print("Кол-во нулевых элементов:", zero_count)
print("Кол-во отриц. элементов:", negative_count)
Результат выполнения программы:
Кол-во полож. элементов: 7 Кол-во нулевых элементов: 2 Кол-во отриц. элементов: 2
Программа проходит по каждому элементу массива и увеличивает соответствующий счетчик в зависимости от значения элемента. Затем она выводит количество положительных, нулевых и отрицательных элементов. В данном случае, в массиве А имеется 7 положительных элементов, 2 нулевых элемента и 2 отрицательных элемента.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
- 
			
Математика
 - 
			
Литература
 - 
			
Алгебра
 - 
			
Русский язык
 - 
			
Геометрия
 - 
			
Английский язык
 - 
			
Химия
 - 
			
Физика
 - 
			
Биология
 - 
			
Другие предметы
 - 
			
История
 - 
			
Обществознание
 - 
			
Окружающий мир
 - 
			
География
 - 
			
Українська мова
 - 
			
Информатика
 - 
			
Українська література
 - 
			
Қазақ тiлi
 - 
			
Экономика
 - 
			
Музыка
 - 
			
Право
 - 
			
Беларуская мова
 - 
			
Французский язык
 - 
			
Немецкий язык
 - 
			
МХК
 - 
			
ОБЖ
 - 
			
Психология
 - 
			
Физкультура и спорт
 - 
			
Астрономия
 - 
			
Кыргыз тили
 - 
			
Оʻzbek tili
 
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			