Вопрос задан 06.07.2023 в 00:12. Предмет Информатика. Спрашивает Дендяк Макс.

. Написать программу ввод целых чисел и подсчёт количества введённых положительных и отрицательных

чисел. Ввод должен осуществляться до тех пор, пока не будет введён ноль. (использовать Цикл с предусловием)
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Барахтей Софія.

num, positive, negative = int(input()), 0, 0

while num:

   if num > 0:

       positive += 1

   else:

       negative += 1

   num = int(input())

print(f'Положительных: {positive}')

print(f'Отрицательных: {negative}')

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот пример программы на языке Python, который выполняет указанную задачу:

python
positive_count = 0 negative_count = 0 while True: num = int(input("Введите целое число (для завершения введите 0): ")) if num == 0: break elif num > 0: positive_count += 1 else: negative_count += 1 print("Количество положительных чисел:", positive_count) print("Количество отрицательных чисел:", negative_count)

Эта программа запрашивает у пользователя ввод целых чисел до тех пор, пока не будет введен ноль. В зависимости от введенного числа, программа увеличивает счетчик положительных или отрицательных чисел. По завершении ввода, программа выводит количество положительных и отрицательных чисел.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос