Вопрос задан 05.07.2023 в 19:23. Предмет Информатика. Спрашивает Сугак Лёша.

Помогите. Нужно написать программу, которая в последовательности чисел определяет их сумму и

количество чётных чисел, кратных 5. Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0(0 - признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000. Программа должна вывести два числа: сумму последовательности и количество чётных чисел, кратных 5. Пример работы программы: Входные данные: 4, 60, 15, 0 Выходные данные: 79, 1 Нужно написать программу на языке Паскаль.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Егошин Дима.

Ответ:

//--- PascalABC.NET 3.6.2 ---//

begin

 var S := ReadSeqIntegerWhile(p -> p <> 0).ToList;

 S.Sum.Println;

 S.Count(p -> (p mod 5 = 0) and (p mod 2 = 0)).Println;

end.

0 0
Отвечает Абдуллин Артём.

// PascalABC.NET

begin

 var (s, k) := (0, 0);

 foreach var n in ReadSeqIntegerWhile(p -> p <> 0) do

 begin

   s += n;

   if n.IsEven and (n mod 5 = 0) then Inc(k)

 end;

 Print('Сумма', s, '   количество', k)

end.

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот пример программы на языке Паскаль, который выполняет указанные вами задачи:

pascal
program SumAndCount; var num, sum, count: integer; begin sum := 0; count := 0; repeat write('Введите число (0 для завершения): '); readln(num); if (num <> 0) then begin sum := sum + num; if (num mod 2 = 0) and (num mod 5 = 0) then count := count + 1; end; until num = 0; writeln('Сумма последовательности: ', sum); writeln('Количество чётных чисел, кратных 5: ', count); end.

Просто скопируйте этот код в среду разработки для Паскаля и выполните его. Программа будет поочередно запрашивать числа, пока не будет введено 0, и после этого выведет сумму последовательности и количество чётных чисел, кратных 5.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос