Вопрос задан 05.07.2023 в 19:01. Предмет Информатика. Спрашивает Ялалова Джамиля.

1. После выполнения заданного фрагмента программы X:=0; Y:=10; Z:=-15; If (X>0)and(Y>0) then

X:=X+Z else X:=X+Y переменная Х будет принимать значение, равное 2. Запишите значение переменной s, полученное в результате работы программы, записанной на языке программирования ABC Pascal: Program Zadacha; Var s,k: integer; Begin s := 0; for k:= 12 to 15 do s:= s + 13; writeln(s); End. (В ответ запишите только число, например, 18).
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Козлов Михаил.

x = 0

y = 0

z = -15

x > 0 и y > 0 - нет

x = x + y

x = 0  + 10

x = 10

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
  1. После выполнения фрагмента программы:
go
X := 0; Y := 10; Z := -15; if (X > 0) and (Y > 0) then X := X + Z else X := X + Y;

Переменная X будет принимать значение 10, так как условие (X > 0) and (Y > 0) ложно, и будет выполнено ветвление X := X + Y.

  1. В данной программе на ABC Pascal:
css
Program Zadacha; Var s, k: integer; Begin s := 0; for k := 12 to 15 do s := s + 13; writeln(s); End.

Переменная s будет принимать значение 52, так как в цикле от 12 до 15 (включительно) переменная s увеличивается на 13 на каждой итерации, итого: 13 + 13 + 13 + 13 = 52.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос