Вопрос задан 05.07.2023 в 18:38.
Предмет Информатика.
Спрашивает Жеребцов Даниил.
Необходимо написать программу в Паскале Записать пять первых положительных элементов массива
Х=(х1,…,х12) подряд в массив Y=(y1,у2,…,у5). Вычислить среднее геометрическое значение элементов массива Y.Ответы на вопрос
Отвечает Таскина Ева.
// PascalABC.NET
begin
var a := ArrRandom(12, -10, 30);
a.Println;
var y := a.Where(p -> p > 0).Take(5).ToArray;
var n := y.Length;
Print(y.Product ** (1 / n))
end.

Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот пример программы на языке Паскаль, который выполняет указанные вами задачи:
pascalprogram GeometricMean; const N = 12; // Размер массива Х M = 5; // Размер массива Y type RealArray = array[1..N] of Real; var X: RealArray; Y: array[1..M] of Real; i: Integer; GeoMean: Real; // Функция для вычисления среднего геометрического function GeometricMeanCalc(arr: array of Real; size: Integer): Real; var i: Integer; product: Real; begin product := 1.0; for i := 0 to size - 1 do product := product * arr[i]; Result := Power(product, 1.0 / size); end; begin // Заполнение массива X (в данном примере случайными значениями) for i := 1 to N do X[i] := Random(100); // Можно использовать другой способ заполнения массива // Запись первых M элементов из массива X в массив Y for i := 1 to M do Y[i] := X[i]; // Вычисление среднего геометрического для массива Y GeoMean := GeometricMeanCalc(Y, M); // Вывод результатов writeln('Массив X:'); for i := 1 to N do write(X[i]:8:2, ' '); writeln; writeln('Массив Y (первые ', M, ' элементов из массива X):'); for i := 1 to M do write(Y[i]:8:2, ' '); writeln; writeln('Среднее геометрическое элементов массива Y:', GeoMean:8:2); readln; end.
Программа создает два массива X и Y, записывает первые пять элементов из массива X в массив Y и затем вычисляет среднее геометрическое значение элементов массива Y. Вы можете изменить способ заполнения массива X и другие параметры по своему усмотрению.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
