Вопрос задан 05.07.2023 в 12:44. Предмет Информатика. Спрашивает Маркова Ксения.

На Python Напишите программу, которая по дате рождения человека определяет, к какому знаку

зодиака относится человек
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Киселев Дима.

date=int(input("Введите день рождения:"))

month=int(input("Введите месяц рождения:"))

year=int(input("Введите год рождения:"))

if (date>=21 and date<=31 and month==3) or( month==4 and date>=1 and date<=19):

   print("Знак зодиака:Овен")

elif (date>=20 and date<=30 and month==4) or( month==5 and date>=1 and date<=20):

   print("Знак зодиака:Телец")

elif (date>=21 and date<=31 and month==5) or( month==6 and date>=1 and date<=21):

   print("Знак зодиака:Близнецы")

elif (date>=22 and date<=30 and month==6) or( month==7 and date>=1 and date<=22):

   print("Знак зодиака:Рак")

elif (date>=23 and date<=31 and month==7) or( month==8 and date>=1 and date<=22):

   print("Знак зодиака:Лев")

elif (date>=23 and date<=31 and month==8) or( month==9 and date>=1 and date<=22):

   print("Знак зодиака:Дева")

elif (date>=23 and date<=30 and month==9) or( month==10 and date>=1 and date<=23):

   print("Знак зодиака:Весы")

elif (date>=24 and date<=31 and month==10) or( month==11 and date>=1 and date<=22):

   print("Знак зодиака:Скорпион")

elif (date>=23 and date<=30 and month==11) or( month==12 and date>=1 and date<=21):

   print("Знак зодиака:Стрелец")

elif (date>=22 and date<=31 and month==12) or( month==1 and date>=1 and date<=20):

   print("Знак зодиака:Козерог")

elif (date>=21 and date<=31 and month==1) or( month==2 and date>=1 and date<=18):

   print("Знак зодиака:Водолей")

elif (date>=19 and date<=29 and month==2) or( month==3 and date>=1 and date<=20):

   print("Знак зодиака:Рыбы")

#Пример входных данных

18

7

2002

Знак зодиака:Рак

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно! Вот пример программы на Python, которая определяет знак зодиака по дате рождения:

python
def zodiac_sign(day, month): if (month == 3 and day >= 21) or (month == 4 and day <= 19): return "Овен" elif (month == 4 and day >= 20) or (month == 5 and day <= 20): return "Телец" elif (month == 5 and day >= 21) or (month == 6 and day <= 20): return "Близнецы" elif (month == 6 and day >= 21) or (month == 7 and day <= 22): return "Рак" elif (month == 7 and day >= 23) or (month == 8 and day <= 22): return "Лев" elif (month == 8 and day >= 23) or (month == 9 and day <= 22): return "Дева" elif (month == 9 and day >= 23) or (month == 10 and day <= 22): return "Весы" elif (month == 10 and day >= 23) or (month == 11 and day <= 21): return "Скорпион" elif (month == 11 and day >= 22) or (month == 12 and day <= 21): return "Стрелец" elif (month == 12 and day >= 22) or (month == 1 and day <= 19): return "Козерог" elif (month == 1 and day >= 20) or (month == 2 and day <= 18): return "Водолей" else: return "Рыбы" # Ввод даты рождения day = int(input("Введите день рождения: ")) month = int(input("Введите месяц рождения: ")) # Определение знака зодиака sign = zodiac_sign(day, month) print(f"Ваш знак зодиака: {sign}")

Программа предоставляет вам возможность ввести день и месяц рождения, а затем выводит соответствующий знак зодиака.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос