
ПОМОГИТЕЕЕ!!! Написать программу на языке СНапишите функцию заполнения массива 10-ю случайными
числами в диапазоне от -40 до 40, функцию вывода элементов массива.

Ответы на вопрос

//Братишка, я тебе С++ принёс
#include <iostream>
#include <ctime>
#include <cstdlib>
using namespace std;
void fill(int arr[10]){
srand(time(NULL));
for(int i = 0;i<10;i++){
arr[i] = rand() % 81 + -40;
}
}
void output(int arr[10]){
for(int i = 0;i<10;i++){
cout<<arr[i]<<endl;
}
}
int main()
{
int arr[10];
fill(arr);
output(arr);
return 0;
}



Конечно, вот пример кода на языке C, который выполняет указанные вами задачи:
c#include <stdio.h>
#include <stdlib.h>
#include <time.h>
void fillArrayWithRandomNumbers(int array[], int size, int min, int max) {
for (int i = 0; i < size; i++) {
array[i] = min + rand() % (max - min + 1);
}
}
void printArray(int array[], int size) {
printf("Array elements: ");
for (int i = 0; i < size; i++) {
printf("%d ", array[i]);
}
printf("\n");
}
int main() {
// Установим seed для генератора случайных чисел, чтобы результаты были разными при каждом запуске
srand(time(NULL));
int array[10];
int min = -40;
int max = 40;
fillArrayWithRandomNumbers(array, 10, min, max);
printArray(array, 10);
return 0;
}
Этот код использует функции fillArrayWithRandomNumbers
для заполнения массива случайными числами в заданном диапазоне и printArray
для вывода элементов массива. Функция srand
устанавливает начальное значение для генератора случайных чисел на основе текущего времени, чтобы каждый раз при запуске программа использовала разные случайные числа.


Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili