Вопрос задан 05.07.2023 в 11:09. Предмет Информатика. Спрашивает Черненко Макс.

PYTHON Рейтинг бакалавра заочного отделения при поступлении в магистратуру определяется средним

баллом по диплому, умноженным на коэффициент стажа работы по специальности, который равен: нет стажа – 1, меньше 2 лет – 13, от 2 до 5 лет – 16. Составить программу расчета рейтинга при заданном среднем балле диплома (от 3 до 5) и вывести сообщение о приеме в магистратуру при проходном балле 45.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Мартынов Владимир.

Python 3.7:

point = float(input('Введите ваш средний балл: '))

while not(3 <= point <= 5):

   point = float(input('Введите ваш средний балл: '))

work_time = float(input('Введите ваш стаж работы по специальности: '))

if work_time == 0:

   k = 1

elif work_time < 2:

   k = 13

else:

   k = 16

print('Вы приняты в магистратуру!' if k*point >= 45 else 'Вы не приняты в магистратуру.')

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, я могу помочь вам с этой задачей. Вот пример программы на языке Python, который выполняет расчет рейтинга и выводит сообщение о приеме в магистратуру:

python
def calculate_rating(average_score, years_of_experience): if years_of_experience == 0: coefficient = 1 elif years_of_experience < 2: coefficient = 13 elif years_of_experience >= 2 and years_of_experience <= 5: coefficient = 16 else: raise ValueError("Invalid years of experience value") rating = average_score * coefficient return rating def main(): try: average_score = float(input("Введите средний балл диплома (от 3 до 5): ")) if average_score < 3 or average_score > 5: raise ValueError("Средний балл должен быть в диапазоне от 3 до 5") years_of_experience = float(input("Введите стаж работы по специальности (в годах): ")) rating = calculate_rating(average_score, years_of_experience) print(f"Рейтинг: {rating}") pass_score = 45 if rating >= pass_score: print("Поздравляем! Вы приняты в магистратуру!") else: print("К сожалению, ваш рейтинг не достаточен для поступления в магистратуру.") except ValueError as e: print(f"Ошибка: {e}") if __name__ == "__main__": main()

Программа предлагает пользователю ввести средний балл диплома и стаж работы по специальности, а затем рассчитывает рейтинг по заданным правилам и выводит сообщение о приеме или неприеме в магистратуру в зависимости от проходного балла.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос