Вопрос задан 05.07.2023 в 05:21. Предмет Информатика. Спрашивает Жигимонт Анна.

(Pyton)Составьте программу вычисления суммы нечетных чисел в диапазоне от 1 до 10.

0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Шульц Наташа.

Ответ:

sum = 0

i = 1

while i <= 10:

   sum += i

   i += 2

print(sum)

0 0
Отвечает Каркынулы Касиет.

Ответ:

def reduce(function, iterable, initializer=None):

   it = iter(iterable)

   if initializer is None:

       value = next(it)

   else:

       value = initializer

   for element in it:

       value = function(value, element)

   return value

a, b = 1, 10

print(reduce(lambda s, n: s + n, range(a, b+1, 2), 0))

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот пример программы на Python для вычисления суммы нечетных чисел в диапазоне от 1 до 10:

python
# Инициализация переменной для хранения суммы нечетных чисел sum_odd = 0 # Проход по числам в диапазоне от 1 до 10 for num in range(1, 11): if num % 2 != 0: # Проверка на нечетность sum_odd += num # Вывод результата print("Сумма нечетных чисел:", sum_odd)

Программа создает цикл, в котором перебираются числа от 1 до 10. Если число нечетное (то есть остаток от деления на 2 не равен 0), оно добавляется к переменной sum_odd. По завершении цикла выводится сумма нечетных чисел.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос