Написать программу на C++ Кольцевая линия Маша и Даша живут около одной остановки кольцевой линии
трамвая. Трамваи ходят по линии в обе стороны. Девочкам надо попасть в кинотеатр, который расположен около другой остановки этой линии. Они сели на трамваи, идущие в разные стороны и начали считать остановки, начиная с той на которой они вошли в трамвай. Они вышли у кинотеатра, причем для Маши это оказалась k-тая остановка, а для Даши m-тая. Напишите программу для определения количества остановок на кольцевой линии. Input format: В одной строке два натуральных числа k и m. Числа не превосходят 100. Output format: Одно число — ответ к задаче.Ответы на вопрос
#include <iostream>
#include <fstream>
using namespace std;
int main()
{
setlocale(0, " ");
ifstream inf("circle.in");
if (inf.is_open())
cout << "Файл circle.in открыт! \n"
<< endl;
else
{
cout << "Файл circle.in не найден!\n"
<< endl;
return -1;
}
int k, m;
inf >> k >> m;
ofstream outf("circle.out");
int s = k + m - 2;
outf << s;
cout << "Ваши данные обработаны!";
return 0;
}
Например, мы имеем кольцевую дорогу из 6 станций (картинка ниже).
Для пути от 4 до 2 получаем k = 5, m = 3.
Для получения количества станций из k и m достаточно сложить эти два числа и вычесть количество дважды посчитанных остановок.
n = k + m - 2
Код:
- #include <iostream>
- int count_train_stations(int k, int m) {
- return k + m - 2;
- }
- int main() {
- int k, m;
- std::cin >> k >> m;
- std::cout << count_train_stations(k, m) << std::endl;
- }



Вот пример программы на языке C++, которая решает данную задачу:
cpp#include <iostream>
int main() {
int k, m;
std::cin >> k >> m;
int totalStops = 0;
if (k <= m) {
totalStops = m - k;
} else {
totalStops = m + (100 - k);
}
std::cout << totalStops << std::endl;
return 0;
}
В данной программе вводятся два натуральных числа k и m, которые представляют номера остановок, на которых Маша и Даша вышли из трамваев соответственно. Затем используется условное выражение, чтобы определить общее количество остановок на кольцевой линии. Если k меньше или равно m, то общее количество остановок равно разнице m - k. В противном случае, к общему количеству остановок добавляется разница между 100 и k, и затем добавляется m. Результат выводится на экран.
Пример ввода:
8 20
Пример вывода:
12
В этом примере Маша (k=8) вышла через 12 остановку после Даши (m=20) на кольцевой линии.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
