Вопрос задан 03.07.2023 в 19:24. Предмет Информатика. Спрашивает Лаптев Саня.

Помогите пожалуйста,программа пайтон !!!!! Подбрасывайте два шестигранных кубика, пока сумма

значений на них не будетравна как минимум 10Пример результата:5758311​
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Дробышева Лиля.

Ответ:

import random

a = random.randint(1, 6)

b = random.randint(1, 6)

while (a+b) <= 10:

   print(a+b)

   a = random.randint(1, 6)

   b = random.randint(1, 6)

print(a+b)

# библиотека random нужна для псевдо-случайной генерации чисел, затем запускаем цикл, пока a+b не будет больше либо равно 10, выводим сумму на экран и заново бросаем кубики

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, я помогу вам написать программу на Python для подбрасывания двух шестигранных кубиков до тех пор, пока сумма значений не станет равной как минимум 10. Вот пример программы:

python
import random def roll_dice(): return random.randint(1, 6) def main(): total = 0 rolls = 0 while total < 10: roll1 = roll_dice() roll2 = roll_dice() total = roll1 + roll2 rolls += 1 print(f"Бросок {rolls}: {roll1} и {roll2} (сумма: {total})") print(f"Достигнута сумма {total} после {rolls} бросков.") if __name__ == "__main__": main()

Вы можете скопировать этот код в файл с расширением .py, например dice_rolling.py, и запустить его в вашей среде разработки Python. Программа будет бросать два кубика до тех пор, пока сумма значений на них не станет равной как минимум 10, и выводить результаты каждого броска, а также общее количество бросков, необходимых для достижения этой суммы.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос