Вопрос задан 03.07.2023 в 17:53.
Предмет Информатика.
Спрашивает Сафронов Кирилл.
Помогите пожалуйста! Информатика,PascalABC Задача №112157. Минимум и максимум из 5 чисел Напишите
программу, которая выбирает максимальное и минимальное из пяти введённых чисел. Входные данные Входная строка содержит 5 целых чисел, разделённых пробелами. Выходные данные В первой строке нужно вывести минимальное из введённых чисел, во второй строке – максимальное. Примеры входные данные 1 2 3 4 5 выходные данные 1 5Ответы на вопрос
Отвечает Боярков Данил.
Ответ:
var
max,min,i,a:integer;
begin
writeln('Введите числа');
max := 0;
for i := 1 to 5 do
begin
read(a);
if(i = 1) then
min :=a;
if(a > max) then
max:= a;
if(a < min) then
min:= a;
end;
Writeln(min);
Writeln(max);
end.
Объяснение:
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот пример программы на PascalABC, которая решает данную задачу:
pascalprogram MinMaxNumbers; var num1, num2, num3, num4, num5: Integer; minNum, maxNum: Integer; begin ReadLn(num1, num2, num3, num4, num5); minNum := num1; maxNum := num1; if num2 < minNum then minNum := num2; if num2 > maxNum then maxNum := num2; if num3 < minNum then minNum := num3; if num3 > maxNum then maxNum := num3; if num4 < minNum then minNum := num4; if num4 > maxNum then maxNum := num4; if num5 < minNum then minNum := num5; if num5 > maxNum then maxNum := num5; WriteLn(minNum); WriteLn(maxNum); end.
Скопируйте этот код в среду PascalABC, запустите программу и введите пять целых чисел через пробел. После ввода программа выведет минимальное и максимальное число.
Похожие вопросы
Информатика 12
Информатика 95
Информатика 27
Информатика 157
Информатика 96
Информатика 46
Информатика 78
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
