Помогите! Плиз. Нужно составить программу. Найдите среднее арифметическое элементов массива А.
Паскаль!Ответы на вопрос
program svs;
const n=7;
var a:array[1..n] of integer;
i,sum:integer;
sarif:real;
begin
sum:=0;
sarif:=0;
writeln ('введите массив');
for i:=1 to n do
begin
write('введите A[',i,']:');
readln(a[i]);
sum:=sum+a[i];
end;
sarif:=sum/n;
writeln ('среднее арифметическое = ',sarif:4:2);
end.
Конечно, я помогу вам! Вот пример программы на языке Паскаль, которая находит среднее арифметическое элементов массива А:
pascalprogram CalculateAverage; const N = 10; // Размер массива var A: array[1..N] of Integer; i: Integer; sum: Integer; average: Real; begin // Заполняем массив случайными числами (можете ввести значения вручную) for i := 1 to N do begin A[i] := Random(100); // Генерируем случайное число от 0 до 99 end; // Вычисляем сумму элементов массива sum := 0; for i := 1 to N do begin sum := sum + A[i]; end; // Вычисляем среднее арифметическое average := sum / N; // Выводим результаты writeln('Массив A:'); for i := 1 to N do begin write(A[i], ' '); end; writeln; writeln('Среднее арифметическое элементов массива A:', average:0:2); end.
В данной программе создается массив A размером N, заполняется случайными числами от 0 до 99 (вы можете ввести значения вручную), затем вычисляется сумма элементов массива и среднее арифметическое. Результаты выводятся на экран.
Обратите внимание, что вам может понадобиться настроить среду выполнения Паскаля и компилятор для запуска данной программы.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
