Вопрос задан 03.07.2023 в 11:08.
Предмет Информатика.
Спрашивает Қабибулла Алмас.
Массив констант содержит информацию о месяцах рождения 10 учащихся класса. Составьте программу
,вычисляющую количество учащихся, родившихся зимой . Pascal Abc
Ответы на вопрос
Отвечает Воробьёв Данил.
Ответ:
const
a:array [1..10] of integer = (12, 5, 4, 1, 9, 7, 8, 2, 3, 2);
var
i,k: integer;
begin
k:=0;
for i:= 1 to 10 do
if (a[i]=12) or (a[i]=1) or (a[i]=2) then k:=k+1;
writeln(k);
end.
Объяснение:
Зима это 12, 1 и 2 месяцы.
Проверяем равен ли элемент массива одному из этих чисел, если равен, то считаем его родившимся зимой.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 31
Информатика 36
Информатика 24
Информатика 43
Информатика 18
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
