Вопрос задан 03.07.2023 в 08:56.
Предмет Информатика.
Спрашивает Gadji Djemil.
Срочно!!! Программа для C, не для C++ Задача №112149. Расстояние Напишите программу, которая
вводит координаты двух точек на числовой оси и выводит расстояние между ними. Входные данные В первой строке вводятся через пробел координаты первой точки (сначала x -координата, потом y -координата), во второй строке в том же порядке – координаты второй точки. Все координаты – вещественные числа. Выходные данные Программа должна вывести одно число: расстояние между точками с тремя знаками в дробной части.Ответы на вопрос
Отвечает Винской Алексей.
#include <stdio.h>
#include <math.h>
int main()
{
double x1, x2;
double y1, y2;
printf("Введіть координати точок:\n");
scanf("%lf%lf%lf%lf, &x1, &x2, &y1, &y2);
double result = sqrt((x1-x2)*(x1-x2) + (y1-y2)*(y1-y2));
printf("%.3lf\n", result)
return 0;
}
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот пример программы на языке C, который решает данную задачу:
c#include <stdio.h>
#include <math.h>
int main() {
double x1, y1, x2, y2;
// Ввод координат первой точки
scanf("%lf %lf", &x1, &y1);
// Ввод координат второй точки
scanf("%lf %lf", &x2, &y2);
// Вычисление расстояния между точками
double distance = sqrt(pow(x2 - x1, 2) + pow(y2 - y1, 2));
// Вывод расстояния с тремя знаками в дробной части
printf("%.3lf\n", distance);
return 0;
}
Программа сначала вводит координаты двух точек, затем использует формулу расстояния между двумя точками в двумерном пространстве и выводит результат с тремя знаками в дробной части.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 33
Информатика 32
Информатика 51
Информатика 95
Информатика 36
Информатика 23
Информатика 36
Информатика 12
Информатика 14
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
