Вопрос задан 02.07.2023 в 19:06.
Предмет Информатика.
Спрашивает Батомункуева Ирина.
С++ помогите Напишите программу, которая запрашивает у пользователя номер дня недели, затем выводит
название дня недели или сообщение об ошибке, если введены неверные данные. Ответы на вопрос
Отвечает Доронина Татьяна.
#include <iostream>
using namespace std;
int main() {
setlocale(LC_ALL, "Russian");
string days[7] = { "Понедельник","Вторник","Среда","Четверг","Пятница","Суббота","Воскресенье" };
int a;
cin >> a;
if (a > 0 && a < 8) {
cout << days[a - 1];
}
else {
cout << "Неверный номер дня недели";
}
return 0;
}
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот пример программы на C++, которая реализует ваше требование:
cpp#include <iostream>
#include <string>
int main() {
int dayNumber;
// Запрашиваем у пользователя номер дня недели
std::cout << "Введите номер дня недели (1-7): ";
std::cin >> dayNumber;
// Проверяем введенное значение и выводим соответствующий день недели
switch (dayNumber) {
case 1:
std::cout << "Понедельник" << std::endl;
break;
case 2:
std::cout << "Вторник" << std::endl;
break;
case 3:
std::cout << "Среда" << std::endl;
break;
case 4:
std::cout << "Четверг" << std::endl;
break;
case 5:
std::cout << "Пятница" << std::endl;
break;
case 6:
std::cout << "Суббота" << std::endl;
break;
case 7:
std::cout << "Воскресенье" << std::endl;
break;
default:
std::cout << "Ошибка: введите номер дня от 1 до 7." << std::endl;
break;
}
return 0;
}
Этот код сначала запрашивает у пользователя номер дня недели. Затем с помощью оператора switch проверяется введенное значение и выводится соответствующее название дня недели или сообщение об ошибке, если значение не входит в диапазон от 1 до 7.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
