
Вопрос задан 01.07.2023 в 23:54.
Предмет Информатика.
Спрашивает Лаврова Наталия.
Срочно только программу C++ В григорианском календаре года нумеруются числами 1, 2, 3 и т.д. -
это года “нашей эры”. Предшествующие года называются “первый год до нашей эры”, “второй год до нашей эры” и т.д. Будем обозначать года нашей эры положительными числами, а года до нашей эры — отрицательными. При этом года с номером 0 не существует, то есть нумерация лет выглядит так: ..., −3, −2, −1, 1, 2, 3, ... В летописях написано, что какое-то событие произошло в году номер A, а другое событие произошло спустя n лет после первого события (или за n лет до первого события). Определите, в каком году произошло второе событие. Формат входных данных Первая строка входных данных содержит число A — год, в котором произошло первое событие. Вторая строка содержит число n. Если n > 0, то второе событие произошло через n лет после первого события, а если n < 0, то второе событие произошло за |n| лет до первого события. Оба числа могут быть как положительными, так и отрицательными. Формат выходных данных Программа должна вывести одно целое число — номер года, в который произошло второе событие.

Ответы на вопрос

Отвечает Городниченко Саша.
Ответ:
#include <iostream>
using namespace std;
int main(){
long long int A;
std::cin >> A;
long long int n;
std::cin >> n;
long long int Answer = A + n;
if(A >= 0 && Answer <= 0 || A <= 0 && Answer >= 0){
if(A >= 0 && Answer <= 0){
Answer--;
}else{
Answer++;
}
}
std::cout << Answer;
return 0;
}
Объяснение:



Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот программа на C++, которая решает данную задачу:
cpp#include <iostream>
int main() {
int yearFirstEvent, yearsDifference;
std::cin >> yearFirstEvent >> yearsDifference;
int yearSecondEvent;
if (yearsDifference >= 0) {
yearSecondEvent = yearFirstEvent + yearsDifference;
} else {
yearSecondEvent = yearFirstEvent - yearsDifference;
}
std::cout << yearSecondEvent << std::endl;
return 0;
}
Вы можете вставить этот код в файл с расширением ".cpp", скомпилировать его с помощью компилятора C++ (например, g++) и выполнить получившийся исполняемый файл. Программа сначала считывает год первого события и разницу в годах между двумя событиями, а затем вычисляет год второго события в соответствии с условиями задачи и выводит его.


Похожие вопросы
Топ вопросов за вчера в категории Информатика

Информатика 558

Информатика 33

Информатика 74

Информатика 12

Информатика 10

Информатика 33

Информатика 27
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili