Вопрос задан 01.07.2023 в 05:14. Предмет Информатика. Спрашивает Лаврова Екатерина.

Составить программу, которая выводит n двузначных натуральных чисел (n вводит пользователь),

которые делятся на 4. Посчитать сумму и количество этих чисел.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Лысенок Денис.

Ответ:

Объяснение:

n=int(input('n='))

s=0

k=0

for i in range(10,99):

   if i%4==0:

       s+=i

       k+=1

       if k==n:

           break

print('Сумма=',s)

print('Количество=',k)

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно! Вот пример программы на языке Python, которая решает вашу задачу:

python
n = int(input("Введите количество двузначных чисел: ")) count = 0 sum = 0 number = 10 while count < n: if number % 4 == 0: print(number) sum += number count += 1 number += 1

В этой программе мы сначала запрашиваем у пользователя количество двузначных чисел n, которые он хочет вывести. Затем мы инициализируем переменные count и sum для отслеживания количества и суммы найденных чисел. Мы также инициализируем переменную number с начальным значением 10, так как первое двузначное число, делящееся на 4, - это 12.

Затем мы запускаем цикл while, который будет выполняться, пока count не достигнет значения n. Внутри цикла мы проверяем, делится ли текущее значение number на 4 без остатка. Если это так, мы выводим число, добавляем его к сумме и увеличиваем значение count на 1. Затем увеличиваем значение number на 1 и переходим к следующей итерации цикла.

Когда цикл завершится, мы выведем общую сумму и количество найденных чисел.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос