Помогите составить программу. Вводятся 2 числа a и b. Где а- натуральное число, b-число от 1 до
9. С помощью цикла найти сколько раз число b встречается внутри числа а. Пример: а=3464 b=4 Результат 2 (раза) Через Паскаль. Var Begin Readln и тдОтветы на вопрос
Ответ:
program z1;
var a,b,k: integer;
begin
k:=0;
write ('a = ');
read(a);
write ('b = ');
read(b);
while a > 0 do
begin
if a mod 10 = b then k:=k+1;
a:=a div 10
end;
write('Результат ',k)
end.
Объяснение:
Вводим числа
Цикл с предусловием
Если последняя цифра числа а равна числу b, то значение k увеличиваем на 1
Изменяем значение а, на целый результат деления на 10
Вывод значения k
mod - остаток от целочисленного деления
div - целочисленное деление
Конечно, вот программа на языке Pascal, которая выполняет указанную задачу:
pascalprogram CountOccurrences; var a, b, count, digit: integer; begin Write('Введите натуральное число a: '); Readln(a); Write('Введите число от 1 до 9 b: '); Readln(b); if (b < 1) or (b > 9) then begin Writeln('Число b должно быть от 1 до 9.'); Exit; end; count := 0; while a > 0 do begin digit := a mod 10; if digit = b then count := count + 1; a := a div 10; end; Writeln('Число ', b, ' встречается в числе ', a, ' ', count, ' раз(а).'); end.
Эта программа сначала запрашивает у пользователя натуральное число a и число b от 1 до 9. Затем она использует цикл while, чтобы разбить число a на отдельные цифры и проверить каждую цифру на равенство с числом b. Если цифра равна b, то счетчик count увеличивается на 1. По завершении цикла программа выводит результат.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
