Вопрос задан 30.06.2023 в 18:31. Предмет Информатика. Спрашивает Романенко Анастасия.

Напишите программу, которая считывает 5 целых чисел, каждое на одной строке записывает их в массив

и печатает этот массив наоборот на одной строке через пробелы. Использовать функции (readln, write, for downto). Пример Ввод 1 2 3 4 5 Вывод 5 4 3 2 1
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Захватова Екатерина.

Ответ:

program z1;

var i: integer;

a:array [1..5] of integer;

begin

for i := 1 to 5 do readln (a[i]);

for i := 5 downto 1 do write (a[i],'  ')

end.

Объяснение:

Цикл со счётчиком:

for i := a to b do, где a <= b (от меньшего к большему)

for i := a downto b do, где a >= b (от большего к меньшему)

readln - ввод следующей строки с новой строки

write - вывод следующей строки с этой же строки

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Для создания программы на Pascal, которая считывает 5 целых чисел, сохраняет их в массиве и выводит этот массив наоборот, вы можете использовать следующий код:

pascal
program ReverseArray; var numbers: array[1..5] of integer; i: integer; begin writeln('Введите 5 целых чисел:'); for i := 1 to 5 do readln(numbers[i]); writeln('Ваш массив в обратном порядке:'); for i := 5 downto 1 do write(numbers[i], ' '); writeln; // Перейти на следующую строку end.

Этот код создает массив numbers из 5 элементов, считывает числа с помощью цикла for, а затем выводит элементы массива в обратном порядке, используя еще один цикл for downto.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос