 
Вопрос задан 30.06.2023 в 01:00.
Предмет Информатика.
Спрашивает Шкитова София.
Напишите программу, которая будет выводить такие правильные числа. А определять их надо так. Из
трёх строк самая короткая – это шаг, с которым нужно выводить числа от длины самой длинной строки до длины оставшейся. Шаг, конечно, нужно сделать отрицательным. И тогда все правильные числа будут, как на ладони! 0
        0
         0
        0
    Ответы на вопрос
 
        Отвечает Бибиков Илья.
                
    str1 = input()
str2 = input()
str3 = input()
mas = [len(str1), len(str2), len(str3)]
mas.sort()
res = [ j for j in range(mas[2], mas[1], -mas[0])]
print(res)
 0
                    0
                     0
                    0
                 
            Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
                
    Программа для вывода правильных чисел в соответствии с заданным шагом можно написать на Python. Вот пример такой программы:
pythondef find_right_numbers(strings):
    # Найдем самую короткую строку
    shortest_length = float('inf')
    for string in strings:
        if len(string) < shortest_length:
            shortest_length = len(string)
    # Вычислим шаг (отрицательный)
    step = -shortest_length
    # Выводим правильные числа
    for length in range(len(strings[-1]), len(strings[0]), step):
        print(length)
# Пример использования программы
strings = ["это", "пример", "трех", "строк"]
find_right_numbers(strings)
Этот код найдет самую короткую строку из списка strings, вычислит шаг как отрицательное значение этой длины, а затем выведет все числа от длины самой длинной строки до длины оставшихся строк с заданным шагом. В данном примере будет выведен ряд чисел от 5 до 2 (включительно), так как самая короткая строка имеет длину 2, а самая длинная строка имеет длину 5.
 0
                    0
                     0
                    0
                Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
	- 
			Математика 
- 
			Литература 
- 
			Алгебра 
- 
			Русский язык 
- 
			Геометрия 
- 
			Английский язык 
- 
			Химия 
- 
			Физика 
- 
			Биология 
- 
			Другие предметы 
- 
			История 
- 
			Обществознание 
- 
			Окружающий мир 
- 
			География 
- 
			Українська мова 
- 
			Информатика 
- 
			Українська література 
- 
			Қазақ тiлi 
- 
			Экономика 
- 
			Музыка 
- 
			Право 
- 
			Беларуская мова 
- 
			Французский язык 
- 
			Немецкий язык 
- 
			МХК 
- 
			ОБЖ 
- 
			Психология 
- 
			Физкультура и спорт 
- 
			Астрономия 
- 
			Кыргыз тили 
- 
			Оʻzbek tili 
 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			